problème mise à jour psql Migration 2.2.0_to_2.3.0

Added by Mat Demb about 1 month ago

Bonjour,
j'ai voulu mettre à jour mon serveur avec la dernière version mais je rencontre des erreurs lors de la migration de la base.
Voici le résultat de la commande:

BEGIN
SET
SET
SET
SET
CREATE FUNCTION
CREATE FUNCTION
CREATE FUNCTION
psql:linshare-core-sql/postgresql/Migration_2.2.0_to_2.3.0.sql:67: INFO: Connected to "linshare" with user "linshare"
ls_check_user_connected
-------------------------

(1 ligne)

psql:linshare-core-sql/postgresql/Migration_2.2.0_to_2.3.0.sql:68: NOTICE: You are about to upgrade from LinShare : 2.2.0 to 2.3.0
psql:linshare-core-sql/postgresql/Migration_2.2.0_to_2.3.0.sql:68: NOTICE: Your actual version is: 2.2.0
psql:linshare-core-sql/postgresql/Migration_2.2.0_to_2.3.0.sql:68: NOTICE: Your databse history is :
psql:linshare-core-sql/postgresql/Migration_2.2.0_to_2.3.0.sql:68: INFO: 2.2.0
psql:linshare-core-sql/postgresql/Migration_2.2.0_to_2.3.0.sql:68: INFO: 2.1.0
psql:linshare-core-sql/postgresql/Migration_2.2.0_to_2.3.0.sql:68: NOTICE: Your database system information is : PostgreSQL 9.2.23 on x86_64-redhat-linux-gnu, compiled by gcc (GCC) 4.8.5 20150623 (Red Hat 4.8.5-16), 64-bit
ls_prechecks
--------------

(1 ligne)

SET
DROP VIEW
DROP VIEW
DROP VIEW
DROP VIEW
DROP VIEW
DROP VIEW
UPDATE 3
DELETE 0
DELETE 0
DELETE 0
DELETE 0
DELETE 0
psql:linshare-core-sql/postgresql/Migration_2.2.0_to_2.3.0.sql:98: ERREUR: erreur de syntaxe sur ou près de « ON »
LIGNE 4 : ON CONFLICT DO NOTHING;
^
psql:linshare-core-sql/postgresql/Migration_2.2.0_to_2.3.0.sql:103: ERREUR: erreur de syntaxe sur ou près de « ON »
LIGNE 4 : ON CONFLICT DO NOTHING;
^
psql:linshare-core-sql/postgresql/Migration_2.2.0_to_2.3.0.sql:108: ERREUR: erreur de syntaxe sur ou près de « ON »
LIGNE 4 : ON CONFLICT DO NOTHING;
^
psql:linshare-core-sql/postgresql/Migration_2.2.0_to_2.3.0.sql:113: ERREUR: erreur de syntaxe sur ou près de « ON »
LIGNE 4 : ON CONFLICT DO NOTHING;
^
psql:linshare-core-sql/postgresql/Migration_2.2.0_to_2.3.0.sql:118: ERREUR: erreur de syntaxe sur ou près de « ON »
LIGNE 4 : ON CONFLICT DO NOTHING;
^
psql:linshare-core-sql/postgresql/Migration_2.2.0_to_2.3.0.sql:157: ERREUR: erreur de syntaxe sur ou près de « ON »
LIGNE 36 : ON CONFLICT DO NOTHING;
^
psql:linshare-core-sql/postgresql/Migration_2.2.0_to_2.3.0.sql:162: ERREUR: erreur de syntaxe sur ou près de « ON »
LIGNE 3 : ON CONFLICT DO NOTHING;
^
psql:linshare-core-sql/postgresql/Migration_2.2.0_to_2.3.0.sql:165: ERREUR: erreur de syntaxe sur ou près de « ON »
LIGNE 3 : ON CONFLICT DO NOTHING;
^
psql:linshare-core-sql/postgresql/Migration_2.2.0_to_2.3.0.sql:168: ERREUR: erreur de syntaxe sur ou près de « ON »
LIGNE 3 : ON CONFLICT DO NOTHING;
^
psql:linshare-core-sql/postgresql/Migration_2.2.0_to_2.3.0.sql:171: ERREUR: erreur de syntaxe sur ou près de « ON »
LIGNE 3 : ON CONFLICT DO NOTHING;
^
psql:linshare-core-sql/postgresql/Migration_2.2.0_to_2.3.0.sql:176: ERREUR: la transaction est annulée, les commandes sont ignorées jusqu'à la fin du bloc
de la transaction
psql:linshare-core-sql/postgresql/Migration_2.2.0_to_2.3.0.sql:181: ERREUR: la transaction est annulée, les commandes sont ignorées jusqu'à la fin du bloc
de la transaction
psql:linshare-core-sql/postgresql/Migration_2.2.0_to_2.3.0.sql:184: ERREUR: la transaction est annulée, les commandes sont ignorées jusqu'à la fin du bloc
de la transaction
psql:linshare-core-sql/postgresql/Migration_2.2.0_to_2.3.0.sql:187: ERREUR: la transaction est annulée, les commandes sont ignorées jusqu'à la fin du bloc
de la transaction
psql:linshare-core-sql/postgresql/Migration_2.2.0_to_2.3.0.sql:191: ERREUR: la transaction est annulée, les commandes sont ignorées jusqu'à la fin du bloc
de la transaction
psql:linshare-core-sql/postgresql/Migration_2.2.0_to_2.3.0.sql:193: ERREUR: la transaction est annulée, les commandes sont ignorées jusqu'à la fin du bloc
de la transaction
psql:linshare-core-sql/postgresql/Migration_2.2.0_to_2.3.0.sql:195: ERREUR: la transaction est annulée, les commandes sont ignorées jusqu'à la fin du bloc
de la transaction
ROLLBACK

Ces erreurs sont-elles génantes pour la suite de la mise à jour?
Cdlt,


Replies (2)

RE: problème mise à jour psql Migration 2.2.0_to_2.3.0 - Added by Mat Demb about 1 month ago

une précision, je suis en CentOS 7.5, PostgreSQL 9.2.24

RE: problème mise à jour psql Migration 2.2.0_to_2.3.0 - Added by Alvin LAMARTINIERE 13 days ago

Bonjour Matt,

La version 2.3 est encore en développement. Cependant, nous prenons en compte votre remarque et ferons en sorte que notre script de migration soit compatible avec les versions antérieures à PostgreSQL 9.5.

Cordialement,

Alvin

(1-2/2)